Konfiguracja telefonii na routerze Cisco (CME/CUCME)

Prezentuję kompletną konfigurację routera Cisco do obsługi telefonii w oparciu o funkcję CME (Call Manager Express), a czasami określaną nazwą CUCME (Cisco Unified Communication Manager Express). Konfiguracja sprzętowa składa się z routera ze środowiskiem CME, przełącznika CISCO, a także telefonu CISCO 7970.

Pierwszą czynnością jest konfiguracja routera od strony interfejsu LAN, którym jest GigabitEthernet 0/1. Wymagana jest konfiguracja VLAN 100 dla ruchu telefonicznego oraz VLAN 101 dla ruchu typowego sieciowego. Konfiguracja routera od strony LAN:

R1(config)# interface g0/1
R1(config-if)# no ip address
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# interface g0/1.100
R1(config-if)# encapsulation dot1q 100
R1(config-if)# ip address 192.168.X.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

R1(config)# interface g0/1.101
R1(config-if)# encapsulation dot1q 101
R1(config-if)# ip address 172.16.X.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

Telefony powinny otrzymywać adres IP dynamicznie (chociaż jest też możliwość pracy z adresami nadanymi statycznie), więc należy skonfigurować DHCP dla telefonów:

R1(config)# ip dhcp pool TELEFONY
R1(config)# network 172.16.X.0 255.255.255.0
R1(config)# default-router 172.16.X.1
R1(config)# option 150 ip 172.16.X.1

Konfiguracja DHCP dla komputerów:

R1(config)# ip dhcp pool KOMPUTERY
R1(config)# network 192.168.X.0 255.255.255.0
R1(config)# default-router 192.168.X.1

Aby udało się zadzwonić na zewnątrz, a także łączyć z Internetem, adresujemy sieć WAN:

R1(config)# int g0/0
R1(config-if)# ip address 10.0.0.X 255.255.255.0
R1(config-if)# no shutdown

Konfigurujemy podstawowy routing statyczny:


R1(config)# ip route 0.0.0.0 0.0.0.0 10.0.0.1

Ustawiamy zegar lub alternatywnie pobieramy czas z serwera NTP:

R1# clock set 14:50:12 5 Dec 2019

Przeprowadzamy konfigurację telefonii na routerze:

R1(config)#telephony-service
R1(config)#ip source-address 172.16.X.1
R1(config)#max-ephone 2
R1(config)#max-dn 2
R1(config)#system message Grupa1
R1(config)#create cnf

Konfigurujemy linię (numer) telefonu:

R1(config)#ephone-dn 1
R1(config)#number X00
R1(config)#name Grupa X
R1(config)#description XXX
R1(config)#label wewqdwq

Konfigurujemy telefon sprzętowy:

R1(config)#ephone 1
R1(config)#mac
R1(config)#type 7970
R1(config)#button 1:1

Router łączymy z portu g0/1 do przełącznika (switch) na port g1/0/1. Konfiguracja przełącznika pod VoiceVLAN oraz QoS:

SW(config)# cdp run

SW(config)# vlan 100
SW(config-vlan)# name KOMPUTERY
SW(config-vlan)# exit

SW(config)# vlan 101
SW(config-vlan)# name TELEFONY
SW(config-vlan)# exit

Konfiguracja portu przełącznika pod telefon i komputer:

SW(config)# interface gigabit 1/0/10
SW(config-if)# switchport mode access
SW(config-if)# switchport access vlan 100
SW(config-if)# switchport voice vlan 101
SW(config-if)# mls qos trust device cisco-phone
SW(config-if)# auto qos voip cisco-phone

Konfigracja portu przełącznika pod komputer:

SW(config)# interface gigabit 1/0/11
SW(config-if)# switchport mode access
SW(config-if)# switchport access vlan 100
SW(config-if)# exit

Konfiguracja portu połączeniowego (trunk) do routera:

SW(config)# interface gigabit 1/0/1
SW(config-if)# switchport mode trunk
SW(config-if)# switchport trunk allowed vlan 100, 101
SW(config-if)# exit

Konfigurujemy QoS na routerze dla głosu:

class-map match-any VOIP-SIGNAL
match ip dscp cs5
match ip precedence 4
match ip precedence 3
class-map match-any VOIP-RTP
match ip dscp ef
match ip precedence 5
!
!
policy-map QOS-Policy
class VOIP-SIGNAL
priority percent 5
class VOIP-RTP
priority percent 70
class class-default
fair-queue
random-detect
!
!
Interface g0/0
bandwidth 4000
service-policy output QoS-Policy

show policy-map interface g0/0

Gdyby pojawiły się pytania lub wątpliwości odnośnie konfiguracji, proszę o komentarze. Na każdy komentarz odpowiem.

Kamil Folga

(Visited 263 times, 1 visits today)

4 thoughts on “Konfiguracja telefonii na routerze Cisco (CME/CUCME)

  • Fajny wpis, szczegółowo, SCCP mamy za sobą :) teraz czas na SIP-a dla modelu telefonu wymienionego w konfiguracji. No i oczywiście instrukcja wgrywania softu.

    • Witam, Tak, jeżeli dopiszemy dodatkową konfigurację dla kolejnych telefonów to będą dzwonić między sobą w ramach domowego LAN. Pozdrawiam!

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Witryna wykorzystuje Akismet, aby ograniczyć spam. Dowiedz się więcej jak przetwarzane są dane komentarzy.

EnglishPolish